Latest news

To use appdb with jailbreak, you must have AppSync installed from our Cydia Repository: https://r.appdb.cc

Use Pangu for iOS<=8.1 and TaiG for iOS <= 8.4

There is no news here yet, but will be soon